Selfhosted
A place to share alternatives to popular online services that can be self-hosted without giving up privacy or locking you into a service you don't control.
Rules:
-
Be civil.
-
No spam.
-
Posts are to be related to self-hosting.
-
Don't duplicate the full text of your blog or readme if you're providing a link.
-
Submission headline should match the article title.
-
No trolling.
-
Promotion posts require active participation, with an account that is at least 30 days old. F/LOSS without a paywall has exceptions, with requirements. See the rules link for details. Tags [CBH] or [AIP] are required, see the links in Rule 8 for details.
-
AI-related discussions and AI-involved promotional posts have additional requirements for tagging, as noted in Rule 7 and the AI & Promotional Post Expanded Rules post, and find example disclosures here.
Resources:
- selfh.st Newsletter and index of selfhosted software and apps
- awesome-selfhosted software
- awesome-sysadmin resources
- Self-Hosted Podcast from Jupiter Broadcasting
Any issues on the community? Report it using the report flag.
Questions? DM the mods!
view the rest of the comments
happens to the best. if fail2ban were any more resiliently engineered it would have failed to start due to the error in the config file
the amount of software I've used that lacks this type of system is aggravating. How hard is it to keep an object of property names, and if the name isn't in it then it errors.
this can be continued into command line as well. if flag -z doesn't exist, you shouldn't allow me to run a command with it. It's clear I am trying to do something (incorrectly) thinking -z is something it isn't, just error it and tell me that.
This is such an underutilized and neglected behavior.
The very least a config parser should do is to log a warning.